about summary refs log tree commit diff
path: root/corepkgs/fetchurl/default.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-07-08T14·19-0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-07-09T19·29-0400
commitc4df7472676cac9bf5243ee8bc7cd0017f91a28d (patch)
treed6d724b878fca138a9d287d6c40c8f5e5c8831b9 /corepkgs/fetchurl/default.nix
parent27f0c34390d6680a843e2d4fad527dc672ed35c6 (diff)
Resurrect old corepkgs fetchurl
Diffstat (limited to '')
-rw-r--r--corepkgs/fetchurl/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/corepkgs/fetchurl/default.nix b/corepkgs/fetchurl/default.nix
new file mode 100644
index 000000000000..37f01b55eeb0
--- /dev/null
+++ b/corepkgs/fetchurl/default.nix
@@ -0,0 +1,23 @@
+# Argh, this thing is duplicated (more-or-less) in Nixpkgs.  Need to
+# find a way to combine them.
+
+{system, url, outputHash ? "", outputHashAlgo ? "", md5 ? "", sha1 ? "", sha256 ? ""}:
+
+assert (outputHash != "" && outputHashAlgo != "")
+    || md5 != "" || sha1 != "" || sha256 != "";
+
+derivation {
+  name = baseNameOf (toString url);
+  builder = ./builder.sh;
+
+  # Compatibility with Nix <= 0.7.
+  id = md5;
+
+  # New-style output content requirements.
+  outputHashAlgo = if outputHashAlgo != "" then outputHashAlgo else
+      if sha256 != "" then "sha256" else if sha1 != "" then "sha1" else "md5";
+  outputHash = if outputHash != "" then outputHash else
+      if sha256 != "" then sha256 else if sha1 != "" then sha1 else md5;
+  
+  inherit system url;
+}