about summary refs log tree commit diff
path: root/corepkgs/fetchurl/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-11-22T18·45+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-11-22T18·45+0000
commitab0bc4999a49efbc8e1c25989662a96e32fa0cc5 (patch)
tree3864cf300fccb46a97decd2d00b8176c047a87d0 /corepkgs/fetchurl/Makefile.am
parent40d9eb14dfb842c51e9f86818b43ae7711e1a5d6 (diff)
* Maintain integrity of the substitute and successor mappings when
  deleting a path in the store.
* Allow absolute paths in Nix expressions.
* Get nix-prefetch-url to work again.
* Various other fixes.

Diffstat (limited to 'corepkgs/fetchurl/Makefile.am')
-rw-r--r--corepkgs/fetchurl/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/corepkgs/fetchurl/Makefile.am b/corepkgs/fetchurl/Makefile.am
index 0c8f0c9399ef..270bf0142488 100644
--- a/corepkgs/fetchurl/Makefile.am
+++ b/corepkgs/fetchurl/Makefile.am
@@ -1,10 +1,11 @@
-all-local: fetchurl.sh
+all-local: builder.sh
 
 install-exec-local:
-	$(INSTALL) -d $(datadir)/fix/fetchurl
-	$(INSTALL_DATA) fetchurl.fix $(datadir)/fix/fetchurl
-	$(INSTALL_PROGRAM) fetchurl.sh $(datadir)/fix/fetchurl
+	$(INSTALL) -d $(datadir)/nix/corepkgs
+	$(INSTALL) -d $(datadir)/nix/corepkgs/fetchurl
+	$(INSTALL_DATA) default.nix $(datadir)/nix/corepkgs/fetchurl
+	$(INSTALL_PROGRAM) builder.sh $(datadir)/nix/corepkgs/fetchurl
 
 include ../../substitute.mk
 
-EXTRA_DIST = fetchurl.fix fetchurl.sh.in
+EXTRA_DIST = default.nix builder.sh.in