about summary refs log tree commit diff
path: root/corepkgs/fetchurl.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-01-16T18·07+0100
committerEelco Dolstra <edolstra@gmail.com>2018-01-16T18·24+0100
commit6ddfe9a999027f9867bbf61ae92c19c591c89a86 (patch)
tree3c1f4903cd74f51741cde772ca4c24306826e09d /corepkgs/fetchurl.nix
parent75b9670df61b3e82e6d60a0572316fdacc9cbd91 (diff)
<nix/fetchurl.nix>: Don't access builtins.currentSystem
This doesn't work in pure evaluation mode.
Diffstat (limited to 'corepkgs/fetchurl.nix')
-rw-r--r--corepkgs/fetchurl.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/corepkgs/fetchurl.nix b/corepkgs/fetchurl.nix
index e135b947fdbb..0ce1bab112f3 100644
--- a/corepkgs/fetchurl.nix
+++ b/corepkgs/fetchurl.nix
@@ -1,4 +1,4 @@
-{ system ? builtins.currentSystem
+{ system ? "" # obsolete
 , url
 , md5 ? "", sha1 ? "", sha256 ? "", sha512 ? ""
 , outputHash ?
@@ -17,7 +17,9 @@ derivation {
   inherit outputHashAlgo outputHash;
   outputHashMode = if unpack || executable then "recursive" else "flat";
 
-  inherit name system url executable unpack;
+  inherit name url executable unpack;
+
+  system = "builtin";
 
   # No need to double the amount of network traffic
   preferLocalBuild = true;