about summary refs log tree commit diff
path: root/corepkgs/fetchurl.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-07-08T14·25-0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-07-09T19·29-0400
commit6450f5699fa824934b92ca7ba1d345c36e9c009a (patch)
tree207b7a3ccf438fd481401a8c9d30e36bfddadd6a /corepkgs/fetchurl.nix
parent40c01ec4671c09a6ceb61ef201dad48156000075 (diff)
Move fetchurl files out of their subdirectory
Diffstat (limited to 'corepkgs/fetchurl.nix')
-rw-r--r--corepkgs/fetchurl.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/corepkgs/fetchurl.nix b/corepkgs/fetchurl.nix
new file mode 100644
index 000000000000..37f01b55eeb0
--- /dev/null
+++ b/corepkgs/fetchurl.nix
@@ -0,0 +1,23 @@
+# Argh, this thing is duplicated (more-or-less) in Nixpkgs.  Need to
+# find a way to combine them.
+
+{system, url, outputHash ? "", outputHashAlgo ? "", md5 ? "", sha1 ? "", sha256 ? ""}:
+
+assert (outputHash != "" && outputHashAlgo != "")
+    || md5 != "" || sha1 != "" || sha256 != "";
+
+derivation {
+  name = baseNameOf (toString url);
+  builder = ./builder.sh;
+
+  # Compatibility with Nix <= 0.7.
+  id = md5;
+
+  # New-style output content requirements.
+  outputHashAlgo = if outputHashAlgo != "" then outputHashAlgo else
+      if sha256 != "" then "sha256" else if sha1 != "" then "sha1" else "md5";
+  outputHash = if outputHash != "" then outputHash else
+      if sha256 != "" then sha256 else if sha1 != "" then sha1 else md5;
+  
+  inherit system url;
+}