about summary refs log tree commit diff
path: root/corepkgs/channels
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2005-03-15T12·03+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2005-03-15T12·03+0000
commitbacd3a6cfa3af1879ef01e693178c74839d66f70 (patch)
treeadbe45ebcc229c82bd60c54500734f9700825716 /corepkgs/channels
parente52ae1c0ffed6af893438cb456c5c38a272c8b21 (diff)
* Purify all corepkgs builders.
Diffstat (limited to 'corepkgs/channels')
-rw-r--r--corepkgs/channels/unpack.sh.in12
1 files changed, 5 insertions, 7 deletions
diff --git a/corepkgs/channels/unpack.sh.in b/corepkgs/channels/unpack.sh.in
index f349f3da3862..332877b9eca5 100644
--- a/corepkgs/channels/unpack.sh.in
+++ b/corepkgs/channels/unpack.sh.in
@@ -1,9 +1,7 @@
 #! @shell@ -e
 
-export PATH=/bin:/usr/bin # !!! impure
-
-mkdir $out
-mkdir $out/tmp
+@coreutils@/mkdir $out
+@coreutils@/mkdir $out/tmp
 cd $out/tmp
 
 expr=$out/default.nix
@@ -12,8 +10,8 @@ echo '[' > $expr
 nr=0
 for i in $inputs; do
     echo "unpacking $i"
-    @bunzip2@ < $i | tar xvf -
-    mv * ../$nr # !!! hacky
+    @bunzip2@ < $i | @tar@ xvf -
+    @coreutils@/mv * ../$nr # !!! hacky
     echo "(import ./$nr)" >> $expr
     nr=$(($nr + 1))
 done
@@ -21,4 +19,4 @@ done
 echo ']' >> $expr
 
 cd ..
-rmdir tmp
\ No newline at end of file
+@coreutils@/rmdir tmp