about summary refs log tree commit diff
path: root/corepkgs/buildenv/default.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2007-04-27T23·28+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2007-04-27T23·28+0000
commita46db5d013a5c3ab5b041824bfb935e5c042886c (patch)
tree5e56daa787c6958582e5e77877d1336e720ca9c8 /corepkgs/buildenv/default.nix
parent3d05166086682b39e013001bdaedb3e8b68a769f (diff)
* Package conflict resolution through priority levels. If there is a
  user environment collission between two packages due to overlapping
  file names, then a package with a higher priority will overwrite the
  symlinks of a package with a lower priority.  E.g.,

    $ nix-env --set-flag priority 5 gcc
    $ nix-env --set-flag priority 10 binutils

  gives gcc a higher priority than binutils (higher number = lower
  priority).

Diffstat (limited to 'corepkgs/buildenv/default.nix')
-rw-r--r--corepkgs/buildenv/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/corepkgs/buildenv/default.nix b/corepkgs/buildenv/default.nix
index a5452db5ea89..36dd9d0c6a0a 100644
--- a/corepkgs/buildenv/default.nix
+++ b/corepkgs/buildenv/default.nix
@@ -4,9 +4,11 @@ derivation {
   name = "user-environment";
   system = system;
   builder = ./builder.pl;
-  derivations = derivations;
+  
   manifest = manifest;
 
   # !!! grmbl, need structured data for passing this in a clean way.
+  paths = derivations;
   active = map (x: if x ? meta && x.meta ? active then x.meta.active else "true") derivations;
+  priority = map (x: if x ? meta && x.meta ? priority then x.meta.priority else "5") derivations;
 }