about summary refs log tree commit diff
path: root/corepkgs/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-07-10T13·41+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-07-10T13·41+0000
commitd072485d2895d01dbbab1d899418726e3349343f (patch)
tree237c23cdb613d363e9205f89d51cac8433cf3b85 /corepkgs/Makefile.am
parent5d4b90b689b09965be39c69aceddaf0b165598d0 (diff)
* Get `nix-push' working again. It now uses Nix/Fix to create Nix
  archives (using the package in corepkgs/nar).
* queryPathByHash -> expandHash, and it takes an argument specifying
  the target path (which may be empty).
* Install the core Fix packages in $prefix/share/fix.  TODO: bootstrap
  Nix and install Nix as a Fix package.

Diffstat (limited to 'corepkgs/Makefile.am')
-rw-r--r--corepkgs/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/corepkgs/Makefile.am b/corepkgs/Makefile.am
new file mode 100644
index 0000000000..9ce9c8c790
--- /dev/null
+++ b/corepkgs/Makefile.am
@@ -0,0 +1,8 @@
+install-data-local:
+	$(INSTALL) -d $(datadir)/fix
+	$(INSTALL) -d $(datadir)/fix/fetchurl
+	$(INSTALL_DATA) fetchurl/fetchurl.fix $(datadir)/fix/fetchurl
+	$(INSTALL_DATA) fetchurl/fetchurl.sh $(datadir)/fix/fetchurl
+	$(INSTALL) -d $(datadir)/fix/nar
+	$(INSTALL_DATA) nar/nar.fix $(datadir)/fix/nar
+	$(INSTALL_DATA) nar/nar.sh $(datadir)/fix/nar