about summary refs log tree commit diff
path: root/corepkgs/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2012-01-03T12·59+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2012-01-03T12·59+0000
commit6c31232e1494d1d68a31fb8433dbf593f831dff2 (patch)
tree9acd7f0e2279bd971b5ccd1f1eb8cec8b7937003 /corepkgs/Makefile.am
parent502d94048ae848eda1fcda2d1e72b339eaa653aa (diff)
parent63227d434cefaa9faeb14afe28ebeb9b2d449ee2 (diff)
* Sync with the trunk.
Diffstat (limited to 'corepkgs/Makefile.am')
-rw-r--r--corepkgs/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/corepkgs/Makefile.am b/corepkgs/Makefile.am
index b303a30eba4a..86d7027ed06e 100644
--- a/corepkgs/Makefile.am
+++ b/corepkgs/Makefile.am
@@ -1 +1,11 @@
-SUBDIRS = nar buildenv channels
+all-local: config.nix
+
+files = nar.nix buildenv.nix buildenv.pl unpack-channel.nix unpack-channel.sh
+
+install-exec-local:
+	$(INSTALL) -d $(DESTDIR)$(datadir)/nix/corepkgs
+	$(INSTALL_DATA) config.nix $(files) $(DESTDIR)$(datadir)/nix/corepkgs
+
+include ../substitute.mk
+
+EXTRA_DIST = config.nix.in $(files)