about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-01-09T13·45+0100
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-01-09T13·51+0100
commit80f464d9d72839841422f75e78ce725365cc3d71 (patch)
tree247398d569884924a45519f0c777417b80dc1e38 /configure.ac
parent013dd28b15c33ff00b4e66d97dd00cb7e2b7d863 (diff)
Escape square brackets in configure.ac
This patch attempts to solve the regression introduced in e8b0efdc
(#2607).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4f00ff0143bd..55600d90bbf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -275,7 +275,7 @@ test "$prefix" = NONE && prefix=$ac_default_prefix
 test "$exec_prefix" = NONE && exec_prefix='${prefix}'
 for name in $ac_subst_vars; do
     for _ in 1 2 3; do
-    if printf '%s' "${name}" | egrep '^[_[:alpha:]][_[:alnum:]]*$'
+    if printf '%s' "${name}" | egrep '^[[_[[:alpha:]]]][[_[[:alnum:]]]]*$'
     then
         eval "${name}"="$(eval echo "\${${name}}")"
     fi