about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-09-09T15·55+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-09-09T15·55+0000
commit5396304c73190c6898981caf653fc1b28be71f70 (patch)
tree3c028375474b943d91e505f5b853fc8abdaa8a02 /configure.ac
parente043fc7d0b68bedaabe236c2f2080a33bb967ee5 (diff)
* Use setre[ug]id() instead of setres[ug]id(), since the former is
  more common than the latter (which exists only on Linux and
  FreeBSD).  We don't really care about dropping the saved IDs since
  there apparently is no way to quiry them in any case, so it can't
  influence the build (unlike the effective IDs which are checked by
  Perl for instance).

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2ba8e92384..6b041c165c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,10 +151,10 @@ if test "$setuid_hack" = "yes"; then
     AC_DEFINE(SETUID_HACK, 1, [whether to install Nix setuid])
 fi
 
-AC_CHECK_FUNC(setresuid, [HAVE_SETRESUID=1], [HAVE_SETRESUID=])
-AM_CONDITIONAL(HAVE_SETRESUID, test "$HAVE_SETRESUID" = "1")
-if test "$HAVE_SETRESUID" = "1"; then
-    AC_DEFINE(HAVE_SETRESUID, 1, [whether we have setresuid()])
+AC_CHECK_FUNC(setreuid, [HAVE_SETREUID=1], [HAVE_SETREUID=])
+AM_CONDITIONAL(HAVE_SETREUID, test "$HAVE_SETREUID" = "1")
+if test "$HAVE_SETREUID" = "1"; then
+    AC_DEFINE(HAVE_SETREUID, 1, [whether we have setreuid()])
 fi
 
 AC_ARG_WITH(nix-user, AC_HELP_STRING([--with-nix-user=USER],