about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-01-12T16·30+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-01-12T16·30+0000
commitc504d90c1159bd0fadd37bb3098ecf8622d0b13c (patch)
tree0c087a0e0d281afae7dbb79910fdc669516b73f2 /configure.ac
parent8e39d9bdb30cbe2e7c3f7d9b30ac64c3a2e32684 (diff)
* Support i686-linux builds directly on x86_64-linux Nix
  installations.  This is implemented using the personality() syscall,
  which causes uname to return "i686" in child processes.

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fdf898640a..44c22c19b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,12 +100,17 @@ AC_CHECK_HEADERS([sys/mount.h], [], [],
 ])
 
 
-# Check for <locale>
+# Check for <locale>.
 AC_LANG_PUSH(C++)
 AC_CHECK_HEADERS([locale], [], [], [])
 AC_LANG_POP(C++)
 
 
+# Check whether we have the personality() syscall, which allows us to
+# do i686-linux builds on x86_64-linux machines.
+AC_CHECK_HEADERS([sys/personality.h])
+
+
 AC_DEFUN([NEED_PROG],
 [
 AC_PATH_PROG($1, $2)