about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-09-14T14·18-0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-09-14T14·18-0400
commitb67466576531959ca298fcfce4f0bf379515f8e5 (patch)
tree54a54395d157226c978bf0187bb9465fe55826a8 /configure.ac
parent09eb23090022fed689c6db6c485d7cc973e2b79e (diff)
Test whether GNU tar understands --warning=no-timestamp
http://hydra.nixos.org/build/3031618
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 17169c885f..743bd8ddff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -340,8 +340,8 @@ AC_SUBST(dynlib_suffix)
 
 
 # Do we have GNU tar?
-AC_MSG_CHECKING([if you have GNU tar])
-if $tar --version 2> /dev/null | grep -q GNU; then
+AC_MSG_CHECKING([if you have a recent GNU tar])
+if $tar --version 2> /dev/null | grep -q GNU && tar cvf /dev/null --warning=no-timestamp ./configure > /dev/null; then
     AC_MSG_RESULT(yes)
     tarFlags="--warning=no-timestamp"
 else