about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-03-02T17·12+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-03-02T17·12+0000
commitd8c5745c41de1a1217cfeac2d4af85146cb87e0f (patch)
tree73db338f7a85ec229228316748b6c3d44cda8975 /configure.ac
parente07d7284a221a11ceda340dea80ed392e0a8a381 (diff)
* Support static builds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4346dde5bb..2c4567c8da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,13 @@ AC_DISABLE_STATIC
 AC_ENABLE_SHARED
 AC_PROG_LIBTOOL
 
+if test "$enable_shared" = yes; then
+   SUB_CONFIGURE_FLAGS="--enable-shared --disable-static"
+else
+   SUB_CONFIGURE_FLAGS="--enable-static --disable-shared"
+fi
+AC_SUBST(SUB_CONFIGURE_FLAGS)
+
 
 # Use 64-bit file system calls so that we can support files > 2 GiB.
 AC_SYS_LARGEFILE