about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2019-02-13T05·03-0500
committerMatthew Bauer <mjbauer95@gmail.com>2019-02-13T05·03-0500
commit7ce1fae59f6cb4341f61a48a5216cb252e4eca54 (patch)
tree949694cbe850b79001cba63612a63d2d2481dc1f /configure.ac
parent7a7ec2229834aa294b3e09df7f514b7134287ec2 (diff)
Support --disable-shared flag.
This tells Nix to not build the shared libraries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5a2526672fdb..410b20972f2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,7 @@ AC_PROG_CXX
 AC_PROG_CPP
 AX_CXX_COMPILE_STDCXX_14
 
+AC_CHECK_TOOL([AR], [ar])
 
 # Use 64-bit file system calls so that we can support files > 2 GiB.
 AC_SYS_LARGEFILE
@@ -267,6 +268,15 @@ AC_ARG_WITH(sandbox-shell, AC_HELP_STRING([--with-sandbox-shell=PATH],
   sandbox_shell=$withval)
 AC_SUBST(sandbox_shell)
 
+AC_ARG_ENABLE(shared, AC_HELP_STRING([--enable-shared],
+  [Build shared libraries for Nix [default=yes]]),
+  shared=$enableval, shared=yes)
+if test "$shared" = yes; then
+  AC_SUBST(BUILD_SHARED_LIBS, 1, [Whether to build shared libraries.])
+else
+  AC_SUBST(BUILD_SHARED_LIBS, 0, [Whether to build shared libraries.])
+fi
+
 
 # Expand all variables in config.status.
 test "$prefix" = NONE && prefix=$ac_default_prefix