about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-09-22T11·13+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-09-22T11·13+0000
commit4cab35d1a691009b43fb0c47574ae0e4baa0b65d (patch)
tree2c22ff2124545db614230416fad1eff9029c01af /configure.ac
parent25df5017046ca5d4f753787532b747cb2c44fec6 (diff)
* Build with -D_FILE_OFFSET_BITS=64 to support files >= 2^31 bytes
  (NIX-22).

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5e3c7f01a3..ac9b54ddd7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,11 @@ AC_ENABLE_SHARED
 AC_PROG_LIBTOOL
 
 
+# Use 64-bit file system calls so that we can support files > 2 GiB.
+CFLAGS="-D_FILE_OFFSET_BITS=64 $CFLAGS"
+CXXFLAGS="-D_FILE_OFFSET_BITS=64 $CXXFLAGS"
+
+
 # Check for pubsetbuf.
 AC_MSG_CHECKING([for pubsetbuf])
 AC_LANG_PUSH(C++)