about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-11-15T18·35+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-11-15T18·35+0100
commitf794465ca8bd2a8d41ee3b6928db5fb1479dc96d (patch)
tree972ed5f7b7327444556b0cdd2c92697a44575673 /configure.ac
parent8541d27fce95f1f6a4a6c89bcbc09503ff7ea092 (diff)
Disable use of vfork()
vfork() is just too weird.  For instance, in this build:

  http://hydra.nixos.org/build/3330487

the value fromHook.writeSide becomes corrupted in the parent, even
though the child only reads from it.  At -O0 the problem goes away.
Probably the child is overriding some spilled temporary variable.

If I get bored I may implement using posix_spawn() instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0eb7d76325..5816d75e50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,7 +116,7 @@ AC_CHECK_HEADERS([sys/mount.h], [], [],
 
 
 # Check for vfork.
-AC_FUNC_FORK()
+#AC_FUNC_FORK()
 
 
 # Check for lutimes, optionally used for changing the mtime of