about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2007-03-01T13·30+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2007-03-01T13·30+0000
commitdb1973d01277278b58253676337e568d5591c01f (patch)
tree70b5c0437bd847ddd434b43317fc486a0fb29fec /configure.ac
parentb4a040e52b607e019515e9339f90a2e5c6c21ad5 (diff)
* Look for the openssl program at compile time. If not found, call
  openssl through $PATH at runtime.

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a83d8f355..7a1c283a20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,6 +126,10 @@ NEED_PROG(perl, perl)
 NEED_PROG(tar, tar)
 AC_PATH_PROG(dot, dot)
 
+AC_PATH_PROG(openssl_prog, openssl, openssl) # if not found, call openssl in $PATH
+AC_SUBST(openssl_prog)
+AC_DEFINE_UNQUOTED(OPENSSL_PATH, ["$openssl_prog"], [Path of the OpenSSL binary])
+
 # Test that Perl has the open/fork feature (Perl 5.8.0 and beyond).
 AC_MSG_CHECKING([whether Perl is recent enough])
 if ! $perl -e 'open(FOO, "-|", "true"); while (<FOO>) { print; }; close FOO or die;'; then