about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2005-07-22T14·52+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2005-07-22T14·52+0000
commit4c20a0829304631cf7282937bd6a0789701f40a4 (patch)
treed28a8304a36c74adf3fb505a4150b6681ad7f63a /configure.ac
parent1a67154d416d3408ac35ddb5a197d1b76f57aab8 (diff)
* Build dynamic libraries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3ec4d7195a..a1c6287db3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ AC_INIT(nix, "0.9")
 AC_CONFIG_SRCDIR(README)
 AC_CONFIG_AUX_DIR(config)
 AM_INIT_AUTOMAKE([dist-bzip2])
-
+        
 # Change to `1' to produce a `stable' release (i.e., the `preREVISION'
 # suffix is not added).
 STABLE=0
@@ -48,6 +48,10 @@ AC_PROG_CC
 AC_PROG_CXX
 AC_PROG_RANLIB
 
+# We are going to use libtool.
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+
 # Check for pubsetbuf.
 AC_MSG_CHECKING([for pubsetbuf])
 AC_LANG_PUSH(C++)