about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-08-01T20·42-0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-08-01T20·42-0400
commit46f852cda013b818f113c7905f020131a44f2340 (patch)
treeb0a7b33f8b3c370a18da777a189a7de010b16055 /configure.ac
parentafa7e0187815d89c8af93fa9c1081bf67ab0f10e (diff)
Use a GNU tar flag to shut up warnings about implausibly old timestamp
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 21a87194f4..bbee7b0612 100644
--- a/configure.ac
+++ b/configure.ac
@@ -339,6 +339,18 @@ eval dynlib_suffix=$shrext_cmds
 AC_SUBST(dynlib_suffix)
 
 
+# Do we have GNU tar?
+AC_MSG_CHECKING([if you have GNU tar])
+if $tar --version 2> /dev/null | grep -q GNU; then
+    AC_MSG_RESULT(yes)
+    tarFlags="--warning=no-timestamp"
+else
+    AC_MSG_RESULT(no)
+fi
+AC_SUBST(tarFlags)
+
+
+
 AM_CONFIG_HEADER([config.h])
 AC_CONFIG_FILES([Makefile
    src/Makefile