about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorJude Taylor <me@jude.bio>2015-10-21T19·38-0700
committerJude Taylor <me@jude.bio>2015-10-21T19·38-0700
commitff6953cb031c0d2a625bbb2df985a7a3bb17bc46 (patch)
tree428b78785f83be8ee4d49bf7082d972b43f17789 /configure.ac
parent15c7a79ed3723c24bbd33f84914d32142da1c2a9 (diff)
Add resolve-system-dependencies.pl
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d4b7d3b89..a30e0c3b24 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,6 +261,23 @@ AC_MSG_RESULT(yes)
 AC_SUBST(perlFlags)
 
 
+# Check for otool, an optional dependency on Darwin.
+AC_PATH_PROG(otool, otool)
+AC_MSG_CHECKING([that otool works])
+case $host_os in
+  darwin*)
+    if test -z "$otool" || ! $otool --version 2>/dev/null; then
+      AC_MSG_RESULT(no)
+      AC_MSG_ERROR([Can't get version from otool; do you need to install developer tools?])
+    fi
+    AC_MSG_RESULT(yes)
+    ;;
+  *)
+    AC_MSG_RESULT(not needed)
+    ;;
+esac
+
+
 # Whether to build the Perl bindings
 AC_MSG_CHECKING([whether to build the Perl bindings])
 AC_ARG_ENABLE(perl-bindings, AC_HELP_STRING([--enable-perl-bindings],