about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-02-16T15·23+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-02-16T15·23+0000
commitf34de121401bb43c6cfab892b2b254e42652ba90 (patch)
tree7d421aefeabf597679a81a92139c9a338be2cfdd /configure.ac
parentfbc48a469c80201f0d159a9b9f48a22ce5f36984 (diff)
* Allow the location of the store to be specified (--with-store-dir).
* Do not create stuff in localstatedir when doing `make install'
  (since we may not have write access).  In general, installation of
  constant code/data should be separate from the initialisation of
  mutable state.

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c6cb782d8f..b8d51916a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,11 @@ AC_ARG_WITH(xml-flags, AC_HELP_STRING([--with-xml-flags=FLAGS],
   xmlflags=$withval, xmlflags=)
 AC_SUBST(xmlflags)
 
+AC_ARG_WITH(store-dir, AC_HELP_STRING([--with-store-dir=PATH],
+  [path of the Nix store]),
+  storedir=$withval, storedir='${prefix}/store')
+AC_SUBST(storedir)
+
 AC_CHECK_LIB(pthread, pthread_mutex_init)
 
 AM_CONFIG_HEADER([config.h])