about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2011-11-18T17·25+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2011-11-18T17·25+0000
commitb92f76374f34068e3a41130cdba88ac2c5924804 (patch)
tree0a3205752a212fe579b91b2a03d4164971e756aa /configure.ac
parent42164d6de493fa2e0acbf1ebaf9ee0d7502b4f0b (diff)
* In the platform, canonicalise "amd64" to "x86_64". FreeBSD 8.2's
  uname reports amd64.
* Drop the FreeBSD version number, e.g. "i686-freebsd" instead of
  "i686-freebsd8.2".

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3cc8eeea2..2ce755d66a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,8 @@ AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
   [case "$host_cpu" in
      i*86)
         machine_name="i686";;
+     amd64)
+        machine_name="x86_64";;
      *)
         machine_name="$host_cpu";;
    esac
@@ -25,6 +27,9 @@ AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
      linux-gnu*)
 	# For backward compatibility, strip the `-gnu' part.
 	system="$machine_name-linux";;
+     freebsd*)
+	# Strip the version number (e.g. freebsd8.2).
+	system="$machine_name-freebsd";;
      *)
         # Strip the version number from names such as `gnu0.3',
         # `darwin10.2.0', etc.