about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2007-05-01T23·16+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2007-05-01T23·16+0000
commit93aefd9fc0250eda2c47d22a88922d319cde34b8 (patch)
tree76ed8bbf3758f48a7b8d594552b80dfbf23540ec /configure.ac
parenta9d15d4f434fece269852a65be836d1338ed787d (diff)
* Give unpacked channels more sensible names than 0, 1, ... They now
  get the basename of the channel URL (e.g., nixpkgs-unstable).  The
  top-level Nix expression of the channel is now an attribute set, the
  attributes of which are the individual channels (e.g.,
  {nixpkgs_unstable = ...; strategoxt_unstable = ...}).  This makes
  attribute paths ("nix-env -qaA" and "nix-env -iA") more sensible,
  e.g., "nix-env -iA nixpkgs_unstable.subversion".

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bc52859c24..350f8791fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -139,6 +139,7 @@ fi
 AC_MSG_RESULT(yes)
 
 NEED_PROG(cat, cat)
+NEED_PROG(tr, tr)
 AC_ARG_WITH(coreutils-bin, AC_HELP_STRING([--with-coreutils-bin=PATH],
   [path of cat, mkdir, etc.]),
   coreutils=$withval, coreutils=$(dirname $cat))