about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2005-09-21T11·12+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2005-09-21T11·12+0000
commit89cd0f57b174ec4dc7e0a4e6015ed401272d9aad (patch)
tree7e1ad8eaa8cd6cc231ac9897e40c568aa85c4017 /configure.ac
parentef9e2c8e733c4cd4f98ebc704527a54588f4a3ca (diff)
* Use -all_load on Mac OS X.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1fa25d8ae..59bc89fb3a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,6 +180,13 @@ AC_SUBST(NIX_GROUP)
 AC_DEFINE_UNQUOTED(NIX_GROUP, ["$NIX_GROUP"], [Nix group])
 
                                                                                                             
+# This is needed if either ATerm or Berkeley DB are static libraries,
+# and the Nix libraries are dynamic.
+if test "$(uname)" = "Darwin"; then
+   LDFLAGS="-all_load $LDFLAGS"
+fi
+
+
 AM_CONFIG_HEADER([config.h])
 AC_CONFIG_FILES([Makefile
    externals/Makefile