about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-07-23T20·52-0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-07-23T20·52-0400
commit6852289c46cdfceb07b459cd1028722ffb124ca6 (patch)
tree014f80b64c1ae569f63703c1e694300280cb11b2 /configure.ac
parent1832ab71dbb6b24965eb5a873a56a7231da7af4e (diff)
Use lutimes() if available to canonicalise the timestamp of symlinks
Also use utimes() instead of utime() if lutimes() is not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7b814dedcb..a2512cfe92 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,11 @@ AC_CHECK_HEADERS([sys/mount.h], [], [],
 ])
 
 
+# Check for lutimes, optionally used for changing the mtime of
+# symlinks.
+AC_CHECK_FUNCS([lutimes])
+
+
 # Check for <locale>.
 AC_LANG_PUSH(C++)
 AC_CHECK_HEADERS([locale])