about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-10-29T14·00+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-10-29T14·00+0000
commit3d71c8013efa5d347b9767af54160b3d0fd9127b (patch)
tree9db9d8b6bef3e85b8e2f4e3e5cf96c45ceab3c98 /configure.ac
parent14fbf85380b23efcc19c8479b65336fc7275d90b (diff)
* Use pkgconfig to locate the Boehm GC (as suggested by Ludo), if
  --enable-gc is given.

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 02eebf6924..f108c53bee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -251,17 +251,17 @@ AC_SUBST(bzip2_bin_test)
 
 
 # Whether to use the Boehm garbage collector.
-AC_ARG_WITH(boehm-gc, AC_HELP_STRING([--with-boehm-gc=PATH],
-  [prefix of the Boehm GC package to enable garbage collection in the Nix expression evaluator]),
-  boehmgc=$withval, boehmgc=)
-if test -n "$boehmgc"; then
+AC_ARG_ENABLE(gc, AC_HELP_STRING([--enable-gc],
+  [enable garbage collection in the Nix expression evaluator (requires Boehm GC)]),
+  gc=$enableval, gc=)
+if test -n "$gc"; then
+  PKG_CHECK_MODULES([BDW_GC], [bdw-gc])
   boehmgc_lib="-L$boehmgc/lib -lgc"
-  CXXFLAGS="-I$boehmgc/include $CXXFLAGS"
+  CXXFLAGS="$BDW_GC_CFLAGS $CXXFLAGS"
   AC_DEFINE(HAVE_BOEHMGC, 1, [Whether to use the Boehm garbage collector.])
 fi
 AC_SUBST(boehmgc_lib)
-AC_SUBST(boehmgc_include)
-  
+
 
 AC_ARG_ENABLE(init-state, AC_HELP_STRING([--disable-init-state],
   [do not initialise DB etc. in `make install']),