about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2011-11-21T12·23+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2011-11-21T12·23+0000
commit23e933b3b3e881515993538ab774c8c7b54f8370 (patch)
tree1f1376722c8ce3ef7857f12b5575181f5475f23f /configure.ac
parenta6abade8e832217c27fade5ab8b7c28003c2ac46 (diff)
* Put back the "sys_name" variable which got removed somewhere. This
  broke building on Cygwin and Solaris.

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 07d67983f7..22139b776b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,14 @@ AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
 	system="$machine_name-`echo $host_os | "$SED" -e's/@<:@0-9.@:>@*$//g'`";;
    esac])
 
+sys_name=$(uname -s | tr 'A-Z ' 'a-z_')
+
+case $sys_name in
+    cygwin*)
+        sys_name=cygwin
+        ;;
+esac
+   
 AC_MSG_RESULT($system)
 AC_SUBST(system)
 AC_DEFINE_UNQUOTED(SYSTEM, ["$system"], [platform identifier (`cpu-os')])
@@ -54,7 +62,7 @@ fi
 
 
 # Solaris-specific stuff.
-if test "$sys_name" = "sunos"; then
+if [ "$sys_name" = sunos ]; then
     # Solaris requires -lsocket -lnsl for network functions
     LIBS="-lsocket -lnsl $LIBS"
 fi