about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2018-02-19T18·13-0600
committerWill Dietz <w@wdtz.org>2018-02-19T18·13-0600
commita6c0b773b72d4e30690e01f1f1dcffc28f2d9ea1 (patch)
treed5f5cef77fbef6ea5a238ce5d31424eb2311fa22 /configure.ac
parent623fcb071e1440a995d8ebcd769d67a45a439711 (diff)
configure.ac: define HAVE_SECCOMP macro when using seccomp, fix build/tests
Happily the failing tests should prevent anyone from using such a Nix
in situations where they expect sandboxing to be on,
which would otherwise be a risk.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4102f32166..54322d463a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,6 +196,7 @@ if test "$sys_name" = linux; then
     PKG_CHECK_MODULES([LIBSECCOMP], [libseccomp],
                       [CXXFLAGS="$LIBSECCOMP_CFLAGS $CXXFLAGS"])
     have_seccomp=1
+    AC_DEFINE([HAVE_SECCOMP], [1], [Whether seccomp is available and should be used for sandboxing.])
   else
     have_seccomp=
   fi