about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Dunham <andrew@du.nham.ca>2018-04-06T07·25-0700
committerAndrew Dunham <andrew@du.nham.ca>2018-04-06T07·25-0700
commit0081a1eac221c996d287240bfe496db26587816b (patch)
treeb7b199c5764a091d08d985ea5470ca6798939793 /configure.ac
parent1d9742b95f1546cc9fa7bc2fe300443c699f198f (diff)
Use $CPPFLAGS when detecting version of aws-sdk-cpp
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7177c89144..c41a83c976 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,7 +215,7 @@ AC_SUBST(ENABLE_S3, [$enable_s3])
 AC_LANG_POP(C++)
 
 if test -n "$enable_s3"; then
-  declare -a aws_version_tokens=($(printf '#include <aws/core/VersionConfig.h>\nAWS_SDK_VERSION_STRING' | $CPP - | grep -v '^#.*' | sed 's/"//g' | tr '.' ' '))
+  declare -a aws_version_tokens=($(printf '#include <aws/core/VersionConfig.h>\nAWS_SDK_VERSION_STRING' | $CPP $CPPFLAGS - | grep -v '^#.*' | sed 's/"//g' | tr '.' ' '))
   AC_DEFINE_UNQUOTED([AWS_VERSION_MAJOR], ${aws_version_tokens@<:@0@:>@}, [Major version of aws-sdk-cpp.])
   AC_DEFINE_UNQUOTED([AWS_VERSION_MINOR], ${aws_version_tokens@<:@1@:>@}, [Minor version of aws-sdk-cpp.])
 fi