about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2012-01-05T20·33+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2012-01-05T20·33+0000
commita7366a764aa8d549a16b58e43181fe4ff7e598ab (patch)
tree9f6b1b1029fef06b5515ae1b23675811d9989dca /configure.ac
parentb52966e821b05e0d2e379ed6bbbf748f22453108 (diff)
* Add a -I flag to the Perl bindings to nix-build and some other
  scripts.
* Include the version and architecture in the -I flag so that there is
  at least a chance that a Nix binary built for one Perl version will
  run on another version.

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1e8665992c..1b6154a2d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -181,6 +181,14 @@ fi
 AC_MSG_RESULT(yes)
 
 
+# Figure out where to install Perl modules.
+AC_MSG_CHECKING([for the Perl installation prefix])
+perlversion=$($perl -e 'use Config; print $Config{version};')
+perlarchname=$($perl -e 'use Config; print $Config{archname};')
+AC_SUBST(perllibdir, [$\(libdir\)/perl5/site_perl/$perlversion/$perlarchname])
+AC_MSG_RESULT($perllibdir)
+
+
 NEED_PROG(cat, cat)
 NEED_PROG(tr, tr)
 AC_ARG_WITH(coreutils-bin, AC_HELP_STRING([--with-coreutils-bin=PATH],
@@ -283,7 +291,7 @@ fi
 
 
 # Check for the required Perl dependencies (DBI and DBD::SQLite).
-perlFlags="-I${libdir}/perl5/site_perl"
+perlFlags="-I$perllibdir"
 
 AC_ARG_WITH(dbi, AC_HELP_STRING([--with-dbi=PATH],
   [prefix of the Perl DBI library]),