about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2011-11-21T12·18+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2011-11-21T12·18+0000
commita6abade8e832217c27fade5ab8b7c28003c2ac46 (patch)
tree605329aebb51c334ce98829fbc62d9e8e3111aaf /configure.ac
parent964399c079f312312f75c41d6f58d323822b6cf0 (diff)
* Escape the [ and ] characters in the sed call, otherwise autoconf
  will eat them.

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f9f3376b52..07d67983f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,7 @@ AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
      *)
         # Strip the version number from names such as `gnu0.3',
         # `darwin10.2.0', etc.
-	system="$machine_name-`echo $host_os | "$SED" -e's/[0-9.]*$//g'`";;
+	system="$machine_name-`echo $host_os | "$SED" -e's/@<:@0-9.@:>@*$//g'`";;
    esac])
 
 AC_MSG_RESULT($system)