about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-09-09T21·12+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-09-09T21·12+0000
commit47f87072ad42338a9b6397a250abf2775d051d8e (patch)
tree6b90037f189ae2b2c750c5c4286b55ef866278d1 /configure.ac
parent5396304c73190c6898981caf653fc1b28be71f70 (diff)
* A very dirty hack to make setuid installations a bit nicer to use.
  Previously there was the problem that all files read by nix-env
  etc. should be reachable and readable by the Nix user.  So for
  instance building a Nix expression in your home directory meant that
  the home directory should have at least g+x or o+x permission so
  that the Nix user could reach the Nix expression.  Now we just
  switch back to the original user just prior to reading sources and
  the like.  The places where this happens are somewhat arbitrary,
  however.  Any scope that has a live SwitchToOriginalUser object in
  it is executed as the original user.

* Back out r1385.  setreuid() sets the saved uid to the new
  real/effective uid, which prevents us from switching back to the
  original uid.  setresuid() doesn't have this problem (although the
  manpage has a bug: specifying -1 for the saved uid doesn't leave it
  unchanged; an explicit value must be specified).

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6b041c165c..2ba8e92384 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,10 +151,10 @@ if test "$setuid_hack" = "yes"; then
     AC_DEFINE(SETUID_HACK, 1, [whether to install Nix setuid])
 fi
 
-AC_CHECK_FUNC(setreuid, [HAVE_SETREUID=1], [HAVE_SETREUID=])
-AM_CONDITIONAL(HAVE_SETREUID, test "$HAVE_SETREUID" = "1")
-if test "$HAVE_SETREUID" = "1"; then
-    AC_DEFINE(HAVE_SETREUID, 1, [whether we have setreuid()])
+AC_CHECK_FUNC(setresuid, [HAVE_SETRESUID=1], [HAVE_SETRESUID=])
+AM_CONDITIONAL(HAVE_SETRESUID, test "$HAVE_SETRESUID" = "1")
+if test "$HAVE_SETRESUID" = "1"; then
+    AC_DEFINE(HAVE_SETRESUID, 1, [whether we have setresuid()])
 fi
 
 AC_ARG_WITH(nix-user, AC_HELP_STRING([--with-nix-user=USER],