about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-11-09T17·00+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-11-09T17·00+0100
commitea89df2b76811505239b508a570ac9c0ea591038 (patch)
tree7b11ea7186ad2b73bf12ebb2e51e7238a052db85 /configure.ac
parent48c19c4633b1443015531ee3032b16b29b0a92f9 (diff)
Use vfork() instead of fork() if available
Hopefully this reduces the chance of hitting ‘unable to fork: Cannot
allocate memory’ errors.  vfork() is used for everything except
starting builders.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7333e03c047f..0eb7d7632596 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,10 @@ AC_CHECK_HEADERS([sys/mount.h], [], [],
 ])
 
 
+# Check for vfork.
+AC_FUNC_FORK()
+
+
 # Check for lutimes, optionally used for changing the mtime of
 # symlinks.
 AC_CHECK_FUNCS([lutimes])