about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorNathan Zadoks <nathan@nathan7.eu>2016-03-11T20·53+0100
committerNathan Zadoks <nathan@nathan7.eu>2016-03-11T20·53+0100
commitc6beaf5708c476b00c59513b253fab0d3dac8d71 (patch)
tree4acee17cb7a2b31cbc613073be0d8191b225ad15 /configure.ac
parent674c5ff64fd518ae7bc64a325b75f0a534e74905 (diff)
Handle ARM triples without an endianness suffix
Alpine seems to use this, and it results in a wrong
builtins.currentSystem. Big-endian ARM systems have triples starting
with armv6eb- or armv7eb-, so this doesn't change any systems that
already worked.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2a043ed13922..1215782a1bde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,8 @@ AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
         machine_name="i686";;
      amd64)
         machine_name="x86_64";;
+     armv6|armv7)
+        machine_name="${host_cpu}l";;
      *)
         machine_name="$host_cpu";;
    esac