about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-12-12T15·36+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-12-12T15·36+0000
commitac36c6cd44e8f46573ce3df0749d2f062fa35f3b (patch)
tree09fd3f8a326d3c6088a5213ca8e04d6d69685d3b /configure.ac
parent2b70a8e7c98adebdac1e546e17ee1d909b4e5989 (diff)
* Some hackery to make "make check" succeed on Cygwin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d5e858123e..fdf898640a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -270,6 +270,17 @@ if test "$(uname)" = "Darwin"; then
 fi
 
 
+if test "$sys_name" = "cygwin"; then
+    # Dynamically linking against the ATerm DLL does work, except that it requires
+    # the ATerm "lib" directory to be in $PATH, as Windows doesn't have anything
+    # like an RPATH embedded in executable.  Since this is kind of annoying, we
+    # use static libraries for now.  This has to happen at the end of
+    # configure, because the C compiler doesn't know about -all-static
+    # (it's filtered out by libtool, but configure doesn't use libtool).
+    LDFLAGS="-all-static $LDFLAGS"
+fi
+
+
 AM_CONFIG_HEADER([config.h])
 AC_CONFIG_FILES([Makefile
    externals/Makefile