about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-12-01T14·36+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-12-01T14·36+0000
commit5d2b424804ec93567ddf15639f84c4098d80f659 (patch)
tree20c27ca1669b8e694bf2f5c4592b8f58e99418b2 /configure.ac
parentdc05f29cf6e1c5ee557441951116ee3fb35e0e00 (diff)
* Use a system name that does not include the OS manufacturer (i.e.,
  "i686-linux" instead of "i686-suse-linux").

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fe5fa136e9..3e0bca31ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,6 +14,14 @@ AC_PREFIX_DEFAULT(/nix)
 
 AC_CANONICAL_HOST
 
+# Construct a Nix system name (like "i686-linux").
+AC_MSG_CHECKING([for the canonical Nix system name])
+machine_name=`uname -m`
+sys_name=`uname -s | tr [A-Z] [a-z]`
+system="${machine_name}-${sys_name}"
+AC_MSG_RESULT($system)
+AC_SUBST(system)
+
 AC_PROG_CC
 AC_PROG_CXX
 AC_PROG_RANLIB