about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-10-19T19·20+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-10-19T19·20+0000
commit1d694eef4ce022a99a3fb552804a1f26f686cc55 (patch)
tree2c4430656986b146b80d022bd15aca0aa1878b63 /configure.ac
parent7a4497d98ca10a3e92d4f94fd62075f336b299b1 (diff)
* Require Perl 5.8.0 or newer. I mean, it *is* more than four years
  old...

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3054abee6b..d24ebd5d84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,7 +122,15 @@ AC_PATH_PROG(bison, bison, false)
 NEED_PROG(perl, perl)
 NEED_PROG(tar, tar)
 AC_PATH_PROG(dot, dot)
-                
+
+# Test that Perl has the open/fork feature (Perl 5.8.0 and beyond).
+AC_MSG_CHECKING([whether Perl is recent enough])
+if ! $perl -e 'open(FOO, "-|", "true"); while (<FOO>) { print; }; close FOO or die;'; then
+    AC_MSG_RESULT(no)
+    AC_MSG_ERROR([Your Perl version is too old.  Nix requires Perl 5.8.0 or newer.])
+fi
+AC_MSG_RESULT(yes)
+
 NEED_PROG(cat, cat)
 AC_ARG_WITH(coreutils-bin, AC_HELP_STRING([--with-coreutils-bin=PATH],
   [path of cat, mkdir, etc.]),