about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-05-18T09·45+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-05-18T09·45+0000
commit1d08093b4894e4ded9eaf591a2547a74d33e1bfb (patch)
tree51e523c106e05ca4a55674d5ac8129b8204dd392 /configure.ac
parent8e9fd57ef9aa47214418212916e54c5644721335 (diff)
* Go back to the old way of generating the system name, and allow it
  to be specified in configure (using `--with-system=SYSTEM').

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index cbca1aecb4..98a9727882 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,9 +22,12 @@ AC_CANONICAL_HOST
 
 # Construct a Nix system name (like "i686-linux").
 AC_MSG_CHECKING([for the canonical Nix system name])
-machine_name=`uname -m`
-sys_name=`uname -s | tr [A-Z] [a-z]`
-system="${machine_name}-${sys_name}"
+#machine_name=`uname -m`
+#sys_name=`uname -s | tr [A-Z] [a-z]`
+#system="${machine_name}-${sys_name}"
+AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
+  [platform identifier (e.g., `i686-linux')]),
+  system=$withval, system="$host_cpu-$host_os")
 AC_MSG_RESULT($system)
 AC_SUBST(system)
 AC_DEFINE_UNQUOTED(SYSTEM, ["$system"], [platform identifier (`cpu-os')])