about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2007-12-14T14·49+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2007-12-14T14·49+0000
commitdf303666bceb5715e706478fad0325447a2a52f6 (patch)
tree90b6ae1a414abfde716e26cfdd49da4ae19879f7 /configure.ac
parent1e90b4189d5b922479a10eac550736d608b038fd (diff)
* Use strsignal if available to give better error messages for
  builders that fail due to a signal.

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 822b15b4b7..581bc4e614 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,6 +256,10 @@ AM_CONDITIONAL(INIT_STATE, test "$init_state" = "yes")
 AC_CHECK_FUNCS([setresuid setreuid lchown])
 
 
+# Nice to have, but not essential.
+AC_CHECK_FUNCS([strsignal])
+
+
 # This is needed if ATerm, Berkeley DB or bzip2 are static libraries,
 # and the Nix libraries are dynamic.
 if test "$(uname)" = "Darwin"; then