about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2017-04-28T14·53+0200
committerEelco Dolstra <edolstra@gmail.com>2017-04-28T14·53+0200
commit73bba12d8ba1bff2b2c0266a7fdbe1ee8ab0ad6a (patch)
tree111b155d26ef6398afcd40205dab9d4f6cf5f6c8 /configure.ac
parenta1a5e63e1456b5905b73065f635a324f3c309a5d (diff)
Check for libreadline
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7026cf954dd..ac37456ae5fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,6 +196,14 @@ if test "$gc" = yes; then
 fi
 
 
+# Check for readline, needed by "nix repl".
+AX_LIB_READLINE
+if test "$ax_cv_lib_readline" != "no"; then
+  have_readline=1
+fi
+AC_SUBST(HAVE_READLINE, [$have_readline])
+
+
 AC_ARG_ENABLE(init-state, AC_HELP_STRING([--disable-init-state],
   [do not initialise DB etc. in `make install']),
   init_state=$enableval, init_state=yes)