about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-10-22T13·39+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-10-22T13·39+0000
commit64c3325b0bef8c0234bf797033e129323b36ad1e (patch)
tree75e6e8d30b204101289a808d7132af9ccb848f82 /configure.ac
parent76feaf016a7e9a9b019148df5ff84a63e48dbda7 (diff)
* Make building against the Boehm GC a configure option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1caa9be5c4..02eebf6924 100644
--- a/configure.ac
+++ b/configure.ac
@@ -250,6 +250,19 @@ AC_SUBST(bzip2_bin)
 AC_SUBST(bzip2_bin_test)
 
 
+# Whether to use the Boehm garbage collector.
+AC_ARG_WITH(boehm-gc, AC_HELP_STRING([--with-boehm-gc=PATH],
+  [prefix of the Boehm GC package to enable garbage collection in the Nix expression evaluator]),
+  boehmgc=$withval, boehmgc=)
+if test -n "$boehmgc"; then
+  boehmgc_lib="-L$boehmgc/lib -lgc"
+  CXXFLAGS="-I$boehmgc/include $CXXFLAGS"
+  AC_DEFINE(HAVE_BOEHMGC, 1, [Whether to use the Boehm garbage collector.])
+fi
+AC_SUBST(boehmgc_lib)
+AC_SUBST(boehmgc_include)
+  
+
 AC_ARG_ENABLE(init-state, AC_HELP_STRING([--disable-init-state],
   [do not initialise DB etc. in `make install']),
   init_state=$enableval, init_state=yes)