about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-08-21T16·05+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-08-21T16·05+0000
commit1a9a1f2768bac5defe4c2e39e5a9ccdee0e05d55 (patch)
treed3d0269ae4b2392edd5b547215fa527283c70725 /configure.ac
parentcc0505f033f9d7f55837dca7b3bb4fb3d2969afb (diff)
* Convert to DocBook 5.
* Use Jing for RelaxNG validation, xmllint seems buggy.

Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 617d2abd23..b6d1212edb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,6 +105,7 @@ NEED_PROG(curl, curl)
 NEED_PROG(shell, sh)
 AC_PATH_PROG(xmllint, xmllint, false)
 AC_PATH_PROG(xsltproc, xsltproc, false)
+AC_PATH_PROG(jing, jing, false) # needed because xmllint --relaxng seems broken
 AC_PATH_PROG(w3m, w3m, false)
 AC_PATH_PROG(flex, flex, false)
 AC_PATH_PROG(bison, bison, false)
@@ -118,10 +119,10 @@ AC_ARG_WITH(coreutils-bin, AC_HELP_STRING([--with-coreutils-bin=PATH],
   coreutils=$withval, coreutils=$(dirname $cat))
 AC_SUBST(coreutils)
 
-AC_ARG_WITH(docbook-catalog, AC_HELP_STRING([--with-docbook-catalog=PATH],
-  [path of the DocBook XML DTD]),
-  docbookcatalog=$withval, docbookcatalog=/docbook-dtd-missing)
-AC_SUBST(docbookcatalog)
+AC_ARG_WITH(docbook-rng, AC_HELP_STRING([--with-docbook-rng=PATH],
+  [path of the DocBook RelaxNG schema]),
+  docbookrng=$withval, docbookrng=/docbook-rng-missing)
+AC_SUBST(docbookrng)
 
 AC_ARG_WITH(docbook-xsl, AC_HELP_STRING([--with-docbook-xsl=PATH],
   [path of the DocBook XSL stylesheets]),