about summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2011-11-20T19·23+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2011-11-20T19·23+0000
commit964399c079f312312f75c41d6f58d323822b6cf0 (patch)
tree7756a434de055430eb841e82b6304ba6999a2f9d /configure.ac
parentb92f76374f34068e3a41130cdba88ac2c5924804 (diff)
* "sed" on FreeBSD doesn't know the "+" operator.
Diffstat (limited to '')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2ce755d66a..f9f3376b52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,13 +27,10 @@ AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
      linux-gnu*)
 	# For backward compatibility, strip the `-gnu' part.
 	system="$machine_name-linux";;
-     freebsd*)
-	# Strip the version number (e.g. freebsd8.2).
-	system="$machine_name-freebsd";;
      *)
         # Strip the version number from names such as `gnu0.3',
         # `darwin10.2.0', etc.
-	system="$machine_name-`echo $host_os | "$SED" -e's/[0-9.]\+$//g'`";;
+	system="$machine_name-`echo $host_os | "$SED" -e's/[0-9.]*$//g'`";;
    esac])
 
 AC_MSG_RESULT($system)