about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2017-10-16T19·46+0200
committerVincent Ambo <tazjin@gmail.com>2017-10-16T19·48+0200
commit7d09557096e277445b60ca80c0b19366ec612432 (patch)
tree439cf67f35c51238a4cb9e2c1f14c95d0bb8da0f /configuration.nix
parent10d1ad92801ce667e07fc4726914e50a13a3e420 (diff)
feat: Add nixpkgs-mozilla overlay
Imports the nixpkgs-mozilla overlay and installs stable Rust from
the same channel as rustup.
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/configuration.nix b/configuration.nix
index 02c6c3288506..64f52aa5f23b 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -4,8 +4,8 @@
 
 { config, pkgs, ... }:
 
-let
-  unstable = import <nixos-unstable> { config.allowUnfree = true; };
+let rust-overlay = import "/etc/nixos/nixpkgs-mozilla/rust-overlay.nix";
+    unstable = import <nixos-unstable> { config.allowUnfree = true; };
 in {
   imports =
     [ # Include the results of the hardware scan.
@@ -13,6 +13,10 @@ in {
     ./local-configuration.nix
     ];
 
+  # Configure the Nix package manager
+  nixpkgs.config.allowUnfree = true;
+  nixpkgs.overlays = [ rust-overlay ];
+
   # Use the systemd-boot EFI boot loader.
   boot.loader.systemd-boot.enable = true;
   boot.loader.efi.canTouchEfiVariables = true;
@@ -26,7 +30,7 @@ in {
   # $ nix-env -qaP | grep wget
   environment.systemPackages = with pkgs; [
     curl gnumake unzip openjdk gcc htop tree direnv tmux fish ripgrep
-    gnupg pass git manpages stdmanpages
+    gnupg pass git manpages stdmanpages latest.rustChannels.stable.rust
   ];
 
   # Enable the X11 windowing system.
@@ -52,7 +56,6 @@ in {
 
   # Configure other random applications:
   programs.java.enable = true;
-  nixpkgs.config.allowUnfree = true;
 
   # Configure fonts
   fonts = {