about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2017-10-20T22·33+0200
committerVincent Ambo <tazjin@gmail.com>2017-10-20T22·33+0200
commit9b7810ae428418907d62765a7724a8362f2952a7 (patch)
tree21a9968f998ec317c593bc5d8509e600b17d8fb4 /configuration.nix
parentbc1f098bac7f8269a668f91a704ff4fc4b0bba49 (diff)
style(all): Consistently use block/attr format & clean up
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix33
1 files changed, 20 insertions, 13 deletions
diff --git a/configuration.nix b/configuration.nix
index aae8c61db41f..4fd9c71d2635 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -20,22 +20,27 @@
   hardware.pulseaudio.enable = true;
   time.timeZone = "Europe/Oslo";
 
-  # Configure shell environment:
-  programs.fish.enable = true;
-  programs.ssh.startAgent = true;
+  # Configure emacs:
+  # (actually, that's a lie, this only installs emacs!)
   services.emacs.enable = true;
   services.emacs.defaultEditor = true;
 
-  # Configure VirtualBox (needed for local NixOps testing):
-  virtualisation.virtualbox.host.enable = true;
+  virtualisation = {
+    # Configure VirtualBox (needed for local NixOps testing):
+    virtualbox.host.enable = true;
 
-  # Configure Docker (with socket activation):
-  # Side note: ... virtualisation? ...
-  virtualisation.docker.enable = true;
-  virtualisation.docker.autoPrune.enable = true;
+    # Configure Docker (with socket activation):
+    # Side note: ... why is this in virtualisation? ...
+    docker.enable = true;
+    docker.autoPrune.enable = true;
+  };
 
-  # Configure other random applications:
-  programs.java.enable = true;
+  # Configure various other applications:
+  programs = {
+    java.enable = true;
+    fish.enable = true;
+    ssh.startAgent = true;
+  };
 
   # Configure user account
   users.defaultUserShell = pkgs.fish;
@@ -46,8 +51,10 @@
     shell = pkgs.fish;
   };
 
-  security.sudo.enable = true;
-  security.sudo.extraConfig = "wheel ALL=(ALL:ALL) SETENV: ALL";
+  security.sudo = {
+    enable = true;
+    extraConfig = "wheel ALL=(ALL:ALL) SETENV: ALL";
+  };
 
   # This value determines the NixOS release with which your system is to be
   # compatible, in order to avoid breaking some software such as database