about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2017-10-16T20·34+0200
committerVincent Ambo <tazjin@gmail.com>2017-10-16T20·34+0200
commitaa5dcbc4777a8e6f42eaee9ac0301d687363e040 (patch)
tree87e5d09fba483a926f99cb3f6724fdbdd84e9a62 /configuration.nix
parent0f099705f7d1942c54e013ca4490c6719d82f23d (diff)
feat: Add Nix build for nixfd
Builds my [nixfd][] tool for searching a cached version of the Nix package
list.

[nixfd]: https://github.com/tazjin/nixfd
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/configuration.nix b/configuration.nix
index 8ace418cdca5..1af903fb255c 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -6,6 +6,7 @@
 
 let rust-overlay = import nixpkgs-mozilla/rust-overlay.nix;
     unstable = import <nixos-unstable> { config.allowUnfree = true; };
+    nixfd = import pkgs/nixfd.nix;
 in {
   imports =
     [ # Include the results of the hardware scan.
@@ -31,6 +32,7 @@ in {
   environment.systemPackages = with pkgs; [
     curl gnumake unzip openjdk gcc htop tree direnv tmux fish ripgrep
     gnupg pass git manpages stdmanpages latest.rustChannels.stable.rust
+    nixfd
   ];
 
   # Enable the X11 windowing system.