about summary refs log tree commit diff
path: root/common-lisp/prove.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-23T13·45+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-23T13·45+0000
commitd262d3054393fe8c445d80269fed9ef7e5b159d8 (patch)
tree264379a2cb4d07554abee620e9696460de9225ad /common-lisp/prove.nix
parent55860debe5e480a043ae47833a218b70a70bf19f (diff)
Attempt to package CL unit testing with Nix
My first foray trying to package Common Lisp with Nix. I'm using @tazjin's
buildLisp and other libraries, all of which I'm importing as `tpkgs`, and all of
which have been a tremendous boon to my productivity.
Diffstat (limited to 'common-lisp/prove.nix')
-rw-r--r--common-lisp/prove.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/common-lisp/prove.nix b/common-lisp/prove.nix
new file mode 100644
index 000000000000..a4499dcea9bb
--- /dev/null
+++ b/common-lisp/prove.nix
@@ -0,0 +1,31 @@
+{ tpkgs ? (import (builtins.fetchGit "https://git.tazj.in/") {}), ... }:
+
+let
+  src = builtins.fetchGit {
+    url = "https://github.com/fukamachi/prove.git";
+    rev = "5d71f02795b89e36f34e8c7d50e69b67ec6ca2de";
+  };
+in tpkgs.nix.buildLisp.library {
+  name = "prove";
+  deps = with tpkgs.third_party.lisp; [
+    cl-ppcre
+    cl-ansi-text
+    (import ./cl-colors.nix {})
+    alexandria
+    uiop
+  ];
+  srcs = [
+    "${src}/src/asdf.lisp"
+    "${src}/src/suite.lisp"
+    "${src}/src/color.lisp"
+    "${src}/src/output.lisp"
+    "${src}/src/prove.lisp"
+    "${src}/src/report.lisp"
+    "${src}/src/reporter.lisp"
+    "${src}/src/test.lisp"
+    "${src}/src/reporter/dot.lisp"
+    "${src}/src/reporter/fiveam.lisp"
+    "${src}/src/reporter/list.lisp"
+    "${src}/src/reporter/tap.lisp"
+  ];
+}