about summary refs log tree commit diff
path: root/common-lisp/anaphora.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-23T13·45+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-23T13·45+0000
commitd262d3054393fe8c445d80269fed9ef7e5b159d8 (patch)
tree264379a2cb4d07554abee620e9696460de9225ad /common-lisp/anaphora.nix
parent55860debe5e480a043ae47833a218b70a70bf19f (diff)
Attempt to package CL unit testing with Nix
My first foray trying to package Common Lisp with Nix. I'm using @tazjin's
buildLisp and other libraries, all of which I'm importing as `tpkgs`, and all of
which have been a tremendous boon to my productivity.
Diffstat (limited to 'common-lisp/anaphora.nix')
-rw-r--r--common-lisp/anaphora.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/common-lisp/anaphora.nix b/common-lisp/anaphora.nix
new file mode 100644
index 000000000000..f64d01a50eee
--- /dev/null
+++ b/common-lisp/anaphora.nix
@@ -0,0 +1,17 @@
+{ tpkgs ? (import (builtins.fetchGit "https://git.tazj.in/") {}), ... }:
+
+let
+  src = builtins.fetchGit {
+    url = "https://github.com/tokenrove/anaphora.git";
+    rev = "aeace4c68cf55098a67112750b28f8f2dc6d0e30";
+  };
+in tpkgs.nix.buildLisp.library {
+  name = "anaphora";
+  deps = [];
+  srcs = [
+    "${src}/packages.lisp"
+    "${src}/early.lisp"
+    "${src}/symbolic.lisp"
+    "${src}/anaphora.lisp"
+  ];
+}