about summary refs log tree commit diff
path: root/client/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-29T08·51+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-29T08·51+0100
commit289cae2528946aa5d745e904cdaaec7df1a71493 (patch)
treebef174f051aa60e7a388a3383b8b19d65b5cbffb /client/shell.nix
parentcf6c8799ab86278c827d4236a7a89163c61c29b9 (diff)
Add Elm boilerplate to project
Create a top-level client directory to store my Elm boilerplate.
Diffstat (limited to 'client/shell.nix')
-rw-r--r--client/shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/client/shell.nix b/client/shell.nix
new file mode 100644
index 000000000000..6f1c8ee23b30
--- /dev/null
+++ b/client/shell.nix
@@ -0,0 +1,9 @@
+let
+  pkgs = import <nixpkgs> {};
+in pkgs.mkShell {
+  buildInputs = with pkgs; [
+    elmPackages.elm
+    elmPackages.elm-format
+    elmPackages.elm-live
+  ];
+}