about summary refs log tree commit diff
path: root/ci/test-install/pubsub/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos O'Ryan <coryan@users.noreply.github.com>2020-01-16T16·04-0500
committerGitHub <noreply@github.com>2020-01-16T16·04-0500
commit52758bec0324a6b120f0bb938f527b1759a0da3d (patch)
tree036e2b7d89f5645b5be7faa25591e2bcaf488453 /ci/test-install/pubsub/CMakeLists.txt
parent20009f59de903d5a70038adee308020a82e3ecad (diff)
feat: add Cloud Pub/Sub protos (#31)
Diffstat (limited to 'ci/test-install/pubsub/CMakeLists.txt')
-rw-r--r--ci/test-install/pubsub/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/ci/test-install/pubsub/CMakeLists.txt b/ci/test-install/pubsub/CMakeLists.txt
new file mode 100644
index 000000000000..cc8d59e187af
--- /dev/null
+++ b/ci/test-install/pubsub/CMakeLists.txt
@@ -0,0 +1,28 @@
+# ~~~
+# Copyright 2019 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ~~~
+
+cmake_minimum_required(VERSION 3.5)
+
+project(utilize-googleapis CXX C)
+
+# Configure the compiler options, we will be using C++11 features.
+set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+find_package(googleapis REQUIRED)
+
+add_executable(utilize-googleapis main.cc)
+target_link_libraries(utilize-googleapis googleapis-c++::pubsub_protos)